Puppy vaccination schedule - Page 2 - German Shepherd Dog Forums
Reply
 
LinkBack Thread Tools
post #11 of 12 (permalink) Old 08-05-2008, 06:32 PM Thread Starter
Junior Member
 
Join Date: Oct 2007
Posts: 33
Re: Puppy vaccination schedule

Well I have 8 other dogs in my home all adults and none vaccinated other then 3 yr. rabies for years. I did have a Parvo pup here 5 months ago so maybe that's why 3weeks apart?

thanks for anyones input,
Sue
suebisaga is offline  
Sponsored Links
Advertisement
 
post #12 of 12 (permalink) Old 03-16-2015, 04:32 AM
New Member
 
Join Date: Mar 2015
Posts: 3
Typically a puppy should get his first shots when he is between six and eight weeks of age and he will need additional vaccination after his first shots. My puppy got the rabies vaccine at four months but this vaccine is set by your county or town. I will get a rabies booster after 1 year.
What shots do puppies need? Puppy vaccination schedule
cmike is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the German Shepherd Dog Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome